RSA Identity Governance & Lifecycle 7.0.0 installation fails with the following error: JBAS014653: Composite operation failed and was rolled back
Originally Published: 2016-05-05
Last Modified: 2023-10-06
Article Number
Applies To
RSA Product/Service Type: Appliance, Hosted
RSA Version/Condition: 7.0.0
Issue
The /tmp/aveksa-install.log shows the following error:
{"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" =>
{"Operation step-2" => {"JBAS014771: Services with missing/unavailable dependencies" =>
["jboss.naming.context.java.comp.aveksa.wpServer.FormUpdatePvt_EJB.env.jdbc.WPDS is missing
The /opt/oracle/wildfly/standalone/log/server.log has contents similar to:
2016-01-19 17:26:41,286 INFO [org.jboss.as] (Controller Boot Thread) JBAS015874: WildFly 8.2.0.Final
"Tweek" started in 20119ms - Started 218 of 267 services (93 services are lazy, passive or on-demand)Cause
There is a scripted component of the installation that is allowing for a 10000 ms response time (10 seconds), and the WildFly server is taking more than 10 seconds to start.
Workaround
- Navigate to /tmp/aveksa/staging/deploy/wildfly-conf/com/aveksa/wildfly.
- Make backups of the Datasources.groovy, Messaging.groovy and Util.groovy files, as shown below:
cd /tmp/aveksa/staging/deploy/wildfly-conf/com/aveksa/wildfly cp -p Datasources.groovy Datasources.groovy.orig cp -p Messaging.groovy Messaging.groovy.orig cp -p Util.groovy Util.groovy.orig
- Open the Datasources.groovy, Messaging.groovy and Util.groovy files in a text editor.
- There will be one occurrence in each file of a setting:
Thread.sleep(10000)
- Change the 10000 to 60000. This will make the install script allow a full minute for the WildFly application to start.
- After making this change attempt to install the product using install.sh.
Related Articles
Unable to execute WinSSHD subsystem 'SftpServer.exe'. The system function CreateProcessAsUser() failed with the following … 16Number of Views Password-Only Authentication 8Number of Views RSA Authentication Manager Web Tier installation fails with the following error: The directory already exists! 53Number of Views While running the RSA Authentication Manager 8.x bulk token sync utility the following e rror is seen: FAILED: Concurrent… 342Number of Views RSA Authentication Manager On-Demand Authentication (ODA) failing with the following error: User provided incorrect On-De… 165Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?