RSA Web Threat Detection (WTD) administrator is not able to create a new user in the administrative interface with the following error: value too long for type character varying(80)
Originally Published: 2016-04-28
Last Modified: 2023-10-06
Article Number
Applies To
RSA Product/Service Type: Administration UI
RSA Version/Condition: 5.1.1.5
Platform: Linux
O/S Version: Red Hat Enterprise Linux 6.x
Product Description: Web Fraud Detection
Issue
Apr 27 09:56:41 testWTD51 uiserver[13342]: [info] 0 [UpdateUser]: DB failure on UPDATE of users table :
ERROR: value too long for type character varying(80)Cause
When rpm-postinstall.sh runs, it will first change the pg_hba.conf to authentication method to “trust.” This should allow for a user to run the updatedb.sh script to upgrade the database. The updatedb.sh script then will check for and implement the resize the column size in the users table for password and prevpassword from 80 to 120 characters. After the resize of those columns the script will do many other updates to the database if needed.
Resolution
Workaround
- Login via SSH to the AnnoDB server and su to postgres
- Login to psql with the command below:
# psql -p 7078 -d silvertail -U postgres
The password for the user is postgres and the default password is changeme.
- Start a transaction in the database and commit it if everything works:
BEGIN; ALTER TABLE users ALTER COLUMN password TYPE varchar(120), ALTER COLUMN prevpasswd TYPE varchar(120);
- Check to see if the varchar has been updated to (120) for password and prevpasswd:
\d users
- If things look correct, as in the example below, then type the following command to finish the commands in step 3 to write the transaction block to the database:
COMMIT;
- If any error is given, or if the TYPE does not match what is shown in the example below, use this command to discard the changes:
ROLLBACK;
- The code below is an example of the expected output:
silvertail=# BEGIN; BEGIN silvertail=# silvertail=# ALTER TABLE users silvertail-# ALTER COLUMN password TYPE varchar(120), silvertail-# ALTER COLUMN prevpasswd TYPE varchar(120); ALTER TABLE silvertail=# silvertail=# \d users Table "public.users" Column | Type | Modifiers -------------+-----------------------------+----------- username | character varying(80) | password | character varying(120) | accesslevel | integer | created | timestamp without time zone | lastlogin | timestamp without time zone | prevpasswd | character varying(120) | expiredate | timestamp without time zone | fails | integer | locked | boolean | tenantid | character varying(200) | Indexes: "users_username_key" UNIQUE, btree (username, tenantid) Referenced by: TABLE "user_preference" CONSTRAINT "user_preference_tenantid_fkey" FOREIGN KEY (tenantid, username) REFERENCES users(tenantid, username) ON DELETE CASCADE TABLE "user_role" CONSTRAINT "user_role_tenantid_fkey" FOREIGN KEY (tenantid, username) REFERENCES users(tenantid, username) ON DELETE CASCADE
Related Articles
RSA Announces Upcoming End of Support for Android 5.1 and Earlier on RSA SecurID Software Token 15Number of Views Failed to create a backup on Windows shared folder for RSA Authentication Manager 8.1 299Number of Views How to create a network trace for RSA Community issues in Mozilla Firefox 37Number of Views AFX Server fails to start and unable to create a new AFX Server on WebSphere in RSA Identity Governance & Lifecycle 120Number of Views How to create an alternate database user for AVUSER and SYS to perform admin taks or troubleshooting in RSA Identity Gover… 267Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?