'Request could not be handled' error exporting metadata from RSA Identity Governance & Lifecycle
Originally Published: 2020-03-16
Article Number
Applies To
RSA Version/Condition: 7.0.x, 7.1.x, 7.2.x
Issue
The request could not be handled
Cause
- Corrupt data in one or more metadata objects being exported.
When exporting metadata, if any of the table definitions being exported have invalid or corrupt data in those tables, the metadata export will fail.
- Insufficient privileges on one or more metadata objects being exported.
When exporting metadata, if any of the table definitions being exported belong to a custom table to which avuser does not have select privileges, the metadata export will fail.
Resolution
If corrupt data is suspected, one known corruption has been reported in RSA Knowledge Base Article 000035732 -- 'Request could not be handled' and 'No enum constant com.aveksa.server.core.DataCollector.Status.InActive' errors exporting metadata from RSA Identity Governance & Lifecycle. For any other suspected data corruption issues that might be affecting the metadata export, please contact RSA Identity Governance & Lifecycle Support for further assistance.
For any custom tables in the avuser schema, follow these steps to grant the proper privileges to those tables:
- Login to SQL as the avuser
- Execute the following SQL grant statement:
grant select on <table | view> to avdwuser
For example:
grant select on custom_table_1 to avdwuser
Notes
$AVEKSA_HOME/database/Create Scripts/Grant_Select_To_Reports.sql
Any tables created after the avdb schema has been created need to have the grant select statement executed manually.Related Articles
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