The message "A programming error has occurred" displays when attempting to register for an RSA Community account
2 years ago
Originally Published: 2018-03-09
Article Number
000040820
Applies To
RSA Product Set: RSA Community (community.rsa.com)
RSA Product/Service Type: RSA Registration Portal (community.rsa.com/register)
Platform: Web Browser
Issue
After attempting to register for an RSA Community account, the error message below is displayed after clicking the Continue button after entering my information.
A programming error has occurred on the server. Please refer to server logs for more information.
User-added image
Cause
This issue is somewhat rare and will generally only occur with RSA employees or RSA customers/partners whose users were migrated from the RSA SecurCare Online (SCOL) platform.  However, it may also occur if the submission timed out. To rule out the possibility of a timeout causing the issue, you should try registering at least twice.
 
In the case of users who were migrated from the RSA SecurCare Online (SCOL) platform that experience the issue, the error message is displayed because the user already exists in the authentication database but has not been fully configured, specifically in regards to setting up one or more Risk-Based Authentication (RBA) methods such as security questions or On-Demand Authentication (ODA).
 
Essentially, the issue is caused by the same situation described in the following article:  Why am I getting an "Access Denied" error when logging in to the RSA Community?
Resolution
To resolve the issue, you must log in to the RSA Self-Service Console and you will be prompted to set up your security questions and/or your On-Demand Authentication.
 
After setting up one or both methods, you will be able to log in successfully to the RSA Community.
 
If you are unsure of any of the steps above or experience any issues, contact RSA Customer Support using the form at https://community.rsa.com/communityhelp and reference this article for further assistance.
Notes
If you do not remember your password then refer to the following article: How do I reset the password for my RSA Community account?
 

Please note that RSA employees will use their corporate login for their RSA Community account and therefore cannot request a password reset.