The server encountered an unexpected condition which prevented it from fulfilling the request when logging out of Self-Service page for RSA Authentication Manager web tier
Originally Published: 2015-04-14
Last Modified: 2022-06-20
Article Number
Applies To
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.x
Issue
- RSA Authentication Manager 8.x is configured with web tiers.
- Log into the Self-Service page via the virtual hostname.
- Log out by clicking the log off link. An error is displayed:
Error: Internal Server Error
The server encountered an unexpected condition which prevented it from fulfilling the request.
- If the user clicks Log off again, the error is gone.
Cause
If you check the adminserver.log on the web tier, you will find the following message identifying the issue:
####<Apr 10, 2015 9:21:57 AM EDT> <Error> <HTTP> <edavis-vm153.na.rsa.net> <AdminServer> <[ACTIVE] ExecuteThread: '1'
for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <d8b9e2ac4e1b2d06:-7cd0996a:14c9ef65fad
:-8000-000000000000015f> <1428672117179> <BEA-101017> <[ServletContext@452341788[app:console-selfservice module:
console-selfservice-8.1.1.2.0.war path:null spec-version:3.0]] Root cause of ServletException.
com.rsa.command.AuditedLocalizableSystemException: COMMAND_EXECUTION_UNEXPECTED_ERROR
Caused by: com.rsa.common.SystemException: Logout request exceeds the configured time window. The webtier time
is not in sync with the biz-tier or a possible replay
at com.rsa.ims.sso.service.CheckAccessCommand.performExecute(CheckAccessCommand.java:180)
at com.rsa.command.LocalTarget.executeCommand(LocalTarget.java:119)
at com.rsa.ims.command.LocalTransactionalCommandTarget.access$0(LocalTransactionalCommandTarget.java:1)
at com.rsa.ims.command.LocalTransactionalCommandTarget$2.doInTransaction(LocalTransactionalCommandTarget.java:268)
at com.rsa.ims.command.LocalTransactionalCommandTarget$2.doInTransaction(LocalTransactionalCommandTarget.java:1)
at org.springframework.transaction.support.TransactionTemplate.execute(TransactionTemplate.java:130)Resolution
If time needs to be updated on the RSA Authentication Manager servers, proceed with caution. Varying the time too much will cause authentication failures. Contact RSA customer support for more information.
Related Articles
Error when logging off the RSA Authentication Manager 8.x Web Tier: 'Error: Internal Server Error. The server encountered … 75Number of Views RSA Identity Governance and Lifecycle Access Fulfillment Express (AFX) Server fails to start with error: An issue with han… 37Number of Views WFLYCTL0344 Operation timed out awaiting service container stability error when patching RSA Identity Governance & Lifecycle 330Number of Views DSA-2019-129: RSA Identity Governance and Lifecycle Security Update for SUSE Linux Enterprise Server Vulnerabilities 12Number of Views The RSA Identity Governance and Lifecycle view for V_AVR_ACCOUNT_ENTITLEMENTS does not include all expected data in RSA Id… 14Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device RSA MFA Agent 2.3.6 for Microsoft Windows Installation and Administration Guide Unable to login to RSA Authentication Manager Security Console as super admin Authentication Manager Security Console and Operations Console Inaccessible After Certificate Update RSA Governance & Lifecycle Integration: Microsoft Azure Active Directory AD Summary
Don't see what you're looking for?