Unable To Delete Unassigned Expired Token
Originally Published: 2016-01-25
Last Modified: 2023-10-06
Article Number
Applies To
RSA Product/Service Type: SecurID Appliance
RSA Version/Condition: 8.1.0
Platform: Linux
O/S Version: SUSE Linux
Issue
Cause
Resolution
Solution 1 : If the issue is seen for a single token, perform the following steps
rsaadmin@am8p:~> cd /opt/rsa/am/utils
rsaadmin@am8p:/opt/rsa/am/utils> ./rsautil manage-secrets -a get com.rsa.db.dba.password
Please enter OC Administrator username: ocadmin
Please enter OC Administrator password: *********
com.rsa.db.dba.password: GrcvNN2FUAsWjyPfhaIsSWvjvZhvtN
cd ../pgsql/bin
rsaadmin@am8p:/opt/rsa/am/pgsql/bin> ./psql -h localhost -p 7050 -d db -U rsa_dba
put the password that appeared
And Query we will run:
select * from rsa_rep.am_ctkip_authcode where token_serial_num like '000112259786';
Delete from rsa_rep.am_ctkip_authcode where token_serial_num like '000112259786';
Solution 2 : If the issue is seen for several random tokens, perform the following steps
rsaadmin@am8p:~> cd /opt/rsa/am/utils
rsaadmin@am8p:/opt/rsa/am/utils> ./rsautil manage-secrets -a get com.rsa.db.dba.password
Please enter OC Administrator username: ocadmin
Please enter OC Administrator password: *********
com.rsa.db.dba.password: GrcvNN2FUAsWjyPfhaIsSWvjvZhvtN
cd ../pgsql/bin
rsaadmin@am8p:/opt/rsa/am/pgsql/bin> ./psql -h localhost -p 7050 -d db -U rsa_dba
put the password that appeared
select token_serial_num from am_ctkip_authcode where is_token_assigned='t' and token_serial_num IN (select serial_number from am_token where token_shutdown_date<='2017-12-31 00:00:00');
Delete from am_ctkip_authcode where is_token_assigned='t' and token_serial_num IN (select serial_number from am_token where token_shutdown_date<='2017-12-31 00:00:00');
Note : Please Backup RSA Database before performing these steps
Related Articles
Generating a report to list unassigned tokens in RSA Authentication Manager 8.x 125Number of Views Enable unassigned RSA SecurID tokens in bulk for RSA Authentication Manager 8.1 SP1 or later 168Number of Views Generic REST Collector fails with 'Access token has expired' error in RSA Identity Governance & Lifecycle 296Number of Views Groups are unassigned in User Access Review for RSA Identity Governance and Lifecycle 38Number of Views RSA Authentication Manager 8.x web tier shows session expired error 119Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?