PAM Agent is failing to connect to RSA Servers (Curl error code: 35)
Originally Published: 2024-04-25
Last Modified: 2026-01-14
Article Number
Applies To
RSA Product/Service Type: Authentication Agent for PAM
Issue
- PAM Agent authentication is failing using REST Protocol showing (Curl error code: 35) in the /var/ace/log/mfa_rest.log
- SSL/TLS Handshake is failing, showing Alert ( Level: Fatal, Description: Illegal Parameter) in the Server Hello.
Cause
Resolution
Upgrade the Internal Authentication Manager Certificates to SHA-256 by following the below article:
Upgrade Internal Authentication Manager Certificates to SHA-256
Related Articles
Failing to access Identity Router IDR Web resource after IDR v2.17 update 116Number of Views Remote AFX Server does not start, there is a SocketException in esb.AFX_INIT.log, and OpenSSL cannot complete an SSL Hands… 339Number of Views Email triggered for 'Please reset your current password' after a password reset 80Number of Views Monitor Uptime Status for Cloud Access Service 135Number of Views Authentication Manager 8.8 update breaks TLS connections; TLS Handshake error no cipher suites in common 183Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?