RSA Identity Governance & Lifecycle installation fails with the following error: <install directory path>/staging/deploy/create_avdb/../../database/cliAveksa.sh: Permission denied
Originally Published: 2016-03-28
Last Modified: 2024-01-11
Article Number
Applies To
RSA Version/Condition: 7.0, 6.9.1, 7.1
Platform: RSA Software Appliance
O/S Version: SUSE 11 SP3, Red Hat
Issue
Starting Oracle... ============================================================================= Customizing AVDB memory settings . . . -------------------------------------------------------------------------- Creating AVDB Instance... sh: /tmp/aveksa/staging/deploy/create_avdb/../../database/cliAveksa.sh: Permission denied sh: /tmp/aveksa/staging/deploy/create_avdb/../../database/cliAveksa.sh: Permission denied -------------------------------------------------------------------------- Checking database connections... Checking database... Failed to connect to the database ERROR: Unable to connect to the database; aborting installation Use "sudo /tmp/aveksa/staging/deploy/configure.sh" to repeat the configuration questions. Use "sudo /tmp/aveksa/staging/deploy/install.sh" to retry the installation
Cause
Workaround
For now the workaround for this issue is to create the oracle user and oinstall group prior to executing install.sh:
groupadd -g 500 oinstall useradd -u 500 -g 500 -d /home/oracle -s /bin/bash oracle
NOTE: If a previous installation was attempted and failed the cleanup steps in knowledge article 000036717 - How to uninstall RSA Identity Governance & Lifecycle must be run prior to re-running the installation. This cleanup purges all files created with the undesired Oracle ID.
Related Articles
RSA Authentication Manager On-Demand Authentication (ODA) failing with the following error: User provided incorrect On-De… 165Number of Views RSA Authentication Manager Web Tier installation fails with the following error: The directory already exists! 53Number of Views On database startup for RSA Identity Governance and Lifecycle the following error is seen: CRS-2501: Resource 'ora.avdb.d… 531Number of Views While running the RSA Authentication Manager 8.x bulk token sync utility the following e rror is seen: FAILED: Concurrent… 342Number of Views Opening RSA SecurID Software Token 4.1.2.30 for Windows Desktop produces the following message: Error loading the applicat… 475Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?