'ClassNotFoundException com.workpoint.applet.ModelApplet' error editing a Workflow in version 7.0.0 or lower of RSA Identity Governance & Lifecycle
4 years ago
Originally Published: 2015-12-17
Article Number
000065365
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle 
RSA Version/Condition: 6.9.1, 7.0.0
 
Issue
When creating or editing a Workflow in RSA Identity Governance & Lifecycle 6.9.1 or 7.0.0 from an Internet Explorer 11 or Firefox web browser, the following error is displayed in the user interface and the create/edit of the Workflow fails (Requests > Workflows > {Workflow-type tab} > {Workflow name}):
 
ClassNotFoundException
com.workpoint.applet.ModelApplet

 
Cause
Java security updates can cause this issue.
 
Resolution
Upgrade to a supported version of RSA Identity Governance & Lifecycle. Supported versions use a new Workflow editor which does not have this issue.
 
Workaround
To workaround this issue in Internet Explorer, follow the steps below:
  1. Enable third-party cookies
  1. In the browser, click the Tools menu.
  2. Click Internet Options.
  3. Select the Privacy tab.
  4. Click Advanced under Settings.
  5. Select Always allow session cookies.
  6. Select the Accept button under Third-party Cookies and click OK.
  1. Remove certificates
  1. Select Start > Configure Java.
  2. Select the Security tab.
  3. Click Manage Certificates.
  4. In Certificate Type, from the drop-down menu, choose Trusted Certificates.
  5. Select all which have Workpoint LLC.
  6. Click Remove.
  1. Disable Verification
  1. Select Start > Configure Java.
  2. Click the Advanced tab.
  3. Under Mixed code (sandboxed vs. trusted) security verification, select Disable verification.
  1. Add the server URL  (https://<IP_address_of_server>:port)
  1. Go to Start > Configure Java
  2. Click the Security tab.
  3. Click Edit Site List.
  4. Click Add.
  5. Enter the URL. Do NOT add /aveksa/main in the URL, only the IP address and port (port is optional).
  1. If all the above fail, try the following:
  1. Install a new or different version of Java. Even going from a 64-bit version to a 32 -bit can sometimes resolve the issue. Be sure to point the browser to the new version from Start > Configure Java > Java tab.  Restart the browser to pick up the new Java version.
  2. Try reinstalling the browser and check the settings as outlined in steps 1 - 4 above.
  3. Try using a different browser such as Chrome or Edge. Sometimes one will work with a particular configuration whereas another browser will not.